InclusiveHost Blog

Security Alert: WordPress 4.7.3 Released

wordpressWordPress 4.7.3 was released today. As this update resolves several cross-site scripting and other vulnerabilities, it is recommended that you update to this version immediately. You can review a full explanation of vulnerabilities fixed on the WordPress website.

You can easily upgrade your WordPress installation in your WordPress Dashboard. Keep in mind that since this update will make changes to your WordPress core files, as well as your database, you’ll want to be sure that you have downloaded a current backup of your site.


As with any popular online software, you should always ensure that you are running the latest available public release of WordPress. This is not only to help ensure you are protected from all known security issues, but also so that you can take full advantage of the latest features. You’ll also want to check any plugins you have installed, and make sure they are updated as well. If you have any plugins installed that you aren’t using, you should remove them as they can also pose a security risk.

Note that InclusiveHost provides basic support for WordPress installation and updates to our customers. If you’re interested in taking advantage of this service, feel free to contact us.